// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?P<quotes>"|''')
(?P<names1>.*?)
\b[Vv]\b
(?P<names2>.*?)
\s*\[?
\s*\b(?P<day>[1-9]|[12]\d|3[01])\b
\s*\b(?P<month>(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\w*)\b
\s*\b(?P<year>\d{4})\b
\s*\]?
\1
"#).unwrap();
let string = "1 \"R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003\",
2 \"H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]\",
3 '''GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND ERIC JOHN WATSON CA CA51/03 26 May 2003'''
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}