import re
regex = re.compile(r"""
(?P<quotes>"|''')
(?P<names1>.*?)
\b[Vv]\b
(?P<names2>.*?)
\s*\[?
\s*\b(?P<day>[1-9]|[12]\d|3[01])\b
\s*\b(?P<month>(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\w*)\b
\s*\b(?P<year>\d{4})\b
\s*\]?
\1
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("1 \"R J BRUCE & OTHERS V B J & W L A EDWARDS And Ors CA CA19/02 27 February 2003\",\n"
"2 \"H v DIRECTOR OF PROCEEDINGS [2014] NZHC 1031 [16 May 2014]\",\n"
"3 '''GREGORY LANCASTER AND JOHN HENRY HUNTER V CULLEN INVESTMENTS LIMITED AND ERIC JOHN WATSON CA CA51/03 26 May 2003'''\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")