using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?|\['([^][]*)']|'([^'\\]*(?:\\.[^'\\]*)*)')";
string input = @"$_['text_1'] = 'text_2 %d \' to %d of %d (%d text)';";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}