re = /(?|\['([^][]*)']|'([^'\\]*(?:\\.[^'\\]*)*)')/
str = '$_[\'text_1\'] = \'text_2 %d \\\' to %d of %d (%d text)\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end