package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|\['([^][]*)']|'([^'\\]*(?:\\.[^'\\]*)*)')`)
var str = `$_['text_1'] = 'text_2 %d \' to %d of %d (%d text)';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}