import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((\\w{0,3})\\)\\s([A-Z,a-z,\\s]+)\\((.*)\\)?\\s+([\\d,.].*)";
final String string = "Source: http://evds.tcmb.gov.tr/fame/webfactory/evdpw/rpt/1652.html \n\n"
+ " 05-02-2016\n\n"
+ "(AUD) Avustralya Dolari (Doviz Alis) 2.08800\n"
+ "(AUD) Avustralya Dolari (Doviz Satis 2.10170\n"
+ "(BEF) Belcika Frangi (Doviz Alis) ..\n"
+ "(BEF) Belcika Frangi (Doviz Satis) ..\n"
+ "(BGN) Bulgar Levasi (Doviz Alis) 1.64750\n"
+ "(BGN) Bulgar Levasi (Doviz Satis) 1.66900\n"
+ "(CHF) Isvicre Frangi (Doviz Alis) 2.89220\n"
+ "(CHF) Isvicre Frangi (Doviz Satis) 2.91070\n"
+ "(EUR) Euro (Doviz Alis) 3.24060\n"
+ "(EUR) Euro (Doviz Satis) 3.24640\n"
+ "(RUB) Rus Rublesi (Doviz Alis) 0.03767\n"
+ "(RUB) Rus Rublesi (Doviz Satis) 0.03817\n"
+ "(USD) ABD Dolari (Doviz Alis) 2.90440\n"
+ "(USD) ABD Dolari (Doviz Satis) 2.90960";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}