# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\((\w{0,3})\)\s([A-Z,a-z,\s]+)\((.*)\)?\s+([\d,.].*)"
test_str = ("Source: http://evds.tcmb.gov.tr/fame/webfactory/evdpw/rpt/1652.html \n\n"
" 05-02-2016\n\n"
"(AUD) Avustralya Dolari (Doviz Alis) 2.08800\n"
"(AUD) Avustralya Dolari (Doviz Satis 2.10170\n"
"(BEF) Belcika Frangi (Doviz Alis) ..\n"
"(BEF) Belcika Frangi (Doviz Satis) ..\n"
"(BGN) Bulgar Levasi (Doviz Alis) 1.64750\n"
"(BGN) Bulgar Levasi (Doviz Satis) 1.66900\n"
"(CHF) Isvicre Frangi (Doviz Alis) 2.89220\n"
"(CHF) Isvicre Frangi (Doviz Satis) 2.91070\n"
"(EUR) Euro (Doviz Alis) 3.24060\n"
"(EUR) Euro (Doviz Satis) 3.24640\n"
"(RUB) Rus Rublesi (Doviz Alis) 0.03767\n"
"(RUB) Rus Rublesi (Doviz Satis) 0.03817\n"
"(USD) ABD Dolari (Doviz Alis) 2.90440\n"
"(USD) ABD Dolari (Doviz Satis) 2.90960")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.