import Foundation
let pattern = #"\((\w{0,3})\)\s([A-Z,a-z,\s]+)\((.*)\)?\s+([\d,.].*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Source: http://evds.tcmb.gov.tr/fame/webfactory/evdpw/rpt/1652.html
05-02-2016
(AUD) Avustralya Dolari (Doviz Alis) 2.08800
(AUD) Avustralya Dolari (Doviz Satis 2.10170
(BEF) Belcika Frangi (Doviz Alis) ..
(BEF) Belcika Frangi (Doviz Satis) ..
(BGN) Bulgar Levasi (Doviz Alis) 1.64750
(BGN) Bulgar Levasi (Doviz Satis) 1.66900
(CHF) Isvicre Frangi (Doviz Alis) 2.89220
(CHF) Isvicre Frangi (Doviz Satis) 2.91070
(EUR) Euro (Doviz Alis) 3.24060
(EUR) Euro (Doviz Satis) 3.24640
(RUB) Rus Rublesi (Doviz Alis) 0.03767
(RUB) Rus Rublesi (Doviz Satis) 0.03817
(USD) ABD Dolari (Doviz Alis) 2.90440
(USD) ABD Dolari (Doviz Satis) 2.90960
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)