using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.\d+\.\d+|\D+(?:\d(?!\d*\.\d+\.\d)\D*)*";
string input = @"oren;moish30.4.200/-/v6.99.5/barbi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}