$re = '/\d+\.\d+\.\d+|\D+(?:\d(?!\d*\.\d+\.\d)\D*)*/m';
$str = 'oren;moish30.4.200/-/v6.99.5/barbi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);