re = /\d+\.\d+\.\d+|\D+(?:\d(?!\d*\.\d+\.\d)\D*)*/m
str = 'oren;moish30.4.200/-/v6.99.5/barbi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end