use strict;
my $str = '//it\'s a commentaire';
my $regex = qr/\/\/([^\n]*)/mp;
my $subst = '/* $1 */';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";