use strict;
my $str = 'john.smith@gmail.com
john@smith@gmail.com';
my $regex = qr/(?!^).(?=.*@)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";