re = /(?!^).(?=.*@)/m
str = 'john.smith@gmail.com
john@smith@gmail.com'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result