import re
regex = re.compile(r"(?!^).(?=.*@)", flags=re.MULTILINE)
test_str = ("john.smith@gmail.com\n"
"john@smith@gmail.com")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)