// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{3}$").unwrap();
let string = "DE34IP315 9 - CASCADE - Found
WA54XC875 9 - CASCADE
WA33XC032 9 - CASCADE
AT99XT805 9 - CASCADE
BI99XT003 9 - CASCADE
CI99XT048 9 - CASCADE
CH03XC397B 10 - CASCADE
CI03XC610 9 - CASCADE
DE34IP936 9 - CASCADE
CR03AW194 9 - CASCADE
ADAMIAG 7 - NSC
LEEVAAA 7 - NSC
LEEVAAB 7 - NSC
COW-AT99XT805 13 - NSC
COW-BI99XT003 13 - NSC
COW-CI99XT048 13 - NSC
HGPKILPI 8 - NSC
WCHSOHDJ 8 - NSC
WHTHMIAA 8 - NSC
LDSNSCAD 8 - NSC
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}