import Foundation
let pattern = #"^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{3}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
DE34IP315 9 - CASCADE - Found
WA54XC875 9 - CASCADE
WA33XC032 9 - CASCADE
AT99XT805 9 - CASCADE
BI99XT003 9 - CASCADE
CI99XT048 9 - CASCADE
CH03XC397B 10 - CASCADE
CI03XC610 9 - CASCADE
DE34IP936 9 - CASCADE
CR03AW194 9 - CASCADE
ADAMIAG 7 - NSC
LEEVAAA 7 - NSC
LEEVAAB 7 - NSC
COW-AT99XT805 13 - NSC
COW-BI99XT003 13 - NSC
COW-CI99XT048 13 - NSC
HGPKILPI 8 - NSC
WCHSOHDJ 8 - NSC
WHTHMIAA 8 - NSC
LDSNSCAD 8 - NSC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)