using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.$)(?=.*\d)(?=.*[%&]+)(?![.\n])(?=.*[A-Z])(?=.*[a-z]).*$";
string substitution = @"";
string input = @"SShiSDSDkhar_01";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}