re = /(?=^.$)(?=.*\d)(?=.*[%&]+)(?![.\n])(?=.*[A-Z])(?=.*[a-z]).*$/
str = 'SShiSDSDkhar_01'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result