$re = '/(?=^.$)(?=.*\d)(?=.*[%&]+)(?![.\n])(?=.*[A-Z])(?=.*[a-z]).*$/';
$str = 'SShiSDSDkhar_01';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;