import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s*$)\\s*(?:(\\d+)\\s*h\\s*)?(?:(\\d+)\\s*m\\s*)?(?:(\\d+)\\s*s)?\\s*$";
final String string = "11h22m33s\n"
+ "11h22m\n"
+ "11h33s\n"
+ "22m33s\n"
+ "11h\n"
+ "22m\n"
+ "33s\n\n"
+ " 11 h22 m 33 s \n"
+ "11 h22 m\n"
+ "11 h 33 s\n"
+ "22 m 33 s";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}