const regex = /^(?!\s*$)\s*(?:(\d+)\s*h\s*)?(?:(\d+)\s*m\s*)?(?:(\d+)\s*s)?\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\s*$)\\s*(?:(\\d+)\\s*h\\s*)?(?:(\\d+)\\s*m\\s*)?(?:(\\d+)\\s*s)?\\s*$', 'gm')
const str = `11h22m33s
11h22m
11h33s
22m33s
11h
22m
33s
11 h22 m 33 s
11 h22 m
11 h 33 s
22 m 33 s`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}