$re = '/^(?!\s*$)\s*(?:(\d+)\s*h\s*)?(?:(\d+)\s*m\s*)?(?:(\d+)\s*s)?\s*$/m';
$str = '11h22m33s
11h22m
11h33s
22m33s
11h
22m
33s
11 h22 m 33 s
11 h22 m
11 h 33 s
22 m 33 s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);