using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"msg_id=""[0-9a-fA-F]{4}-[0-9a-fA-F]{4}""(?:\s+Authentication of)?\s+(.*?\s[Uu]ser)\s\[?([^\[\]\s]+)";
string input = @"msg_id=""1100-0005"" Authentication of Firewall user [someuser@somehost] from fe80::badd:cafe was rejected, password is incorrect
msg_id=""5000-0001"" WebUI User anotheruser@anotherhost from 10.0.0.2 log in attempt was rejected - invalid credentials.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}