package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)msg_id="[0-9a-fA-F]{4}-[0-9a-fA-F]{4}"(?:\s+Authentication of)?\s+(.*?\s[Uu]ser)\s\[?([^\[\]\s]+)`)
var str = `msg_id="1100-0005" Authentication of Firewall user [someuser@somehost] from fe80::badd:cafe was rejected, password is incorrect
msg_id="5000-0001" WebUI User anotheruser@anotherhost from 10.0.0.2 log in attempt was rejected - invalid credentials.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}