import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "msg_id=\"[0-9a-fA-F]{4}-[0-9a-fA-F]{4}\"(?:\\s+Authentication of)?\\s+(.*?\\s[Uu]ser)\\s\\[?([^\\[\\]\\s]+)";
final String string = "msg_id=\"1100-0005\" Authentication of Firewall user [someuser@somehost] from fe80::badd:cafe was rejected, password is incorrect\n"
+ "msg_id=\"5000-0001\" WebUI User anotheruser@anotherhost from 10.0.0.2 log in attempt was rejected - invalid credentials.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}