#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+)\t[0-9]+\n\1\t●"
Local $sString = "Collection 47" & @CRLF & _
"Collection ●" & @CRLF & _
"CollectionIdentifier 50" & @CRLF & _
"CollectionIdentifier ●" & @CRLF & _
"CollectionIDType 51" & @CRLF & _
"CollectionIDType ●" & @CRLF & _
"CollectionSequence 52" & @CRLF & _
"CollectionSequenceNumber 55" & @CRLF & _
"CollectionSequenceType 53" & @CRLF & _
"CollectionSequenceTypeName 54" & @CRLF & _
"CollectionType 48" & @CRLF & _
"CollectionType ●" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")