use strict;
my $str = 'Collection 47
Collection ●
CollectionIdentifier 50
CollectionIdentifier ●
CollectionIDType 51
CollectionIDType ●
CollectionSequence 52
CollectionSequenceNumber 55
CollectionSequenceType 53
CollectionSequenceTypeName 54
CollectionType 48
CollectionType ●
';
my $regex = qr/^(.+)\t[0-9]+\n\1\t●/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}