#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?msi)2014(?:(?!2014).)*?baloon.*?(?=\n2014)"
Local $sString = "2014.10.30: b" & @CRLF & _
"l" & @CRLF & _
"ah bl" & @CRLF & _
"a" & @CRLF & _
"h " & @CRLF & _
"2014.10.30: bfoo " & @CRLF & _
"lah " & @CRLF & _
"b " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"2014.10.30: bart1 " & @CRLF & _
"lah " & @CRLF & _
"baloon " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"2014.10.30: carb " & @CRLF & _
"lah " & @CRLF & _
"b " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"2014.10.30: farb2 " & @CRLF & _
"lah " & @CRLF & _
"baloon " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"2014.10.30: carb " & @CRLF & _
"lah " & @CRLF & _
"b " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"2014.10.30: bom " & @CRLF & _
"lah " & @CRLF & _
"baloob " & @CRLF & _
"l " & @CRLF & _
"ah " & @CRLF & _
"etc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")