const regex = /2014(?:(?!2014).)*?baloon.*?(?=\n2014)/gmsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('2014(?:(?!2014).)*?baloon.*?(?=\\n2014)', 'gmsi')
const str = `2014.10.30: b
l
ah bl
a
h
2014.10.30: bfoo
lah
b
l
ah
2014.10.30: bart1
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: farb2
lah
baloon
l
ah
2014.10.30: carb
lah
b
l
ah
2014.10.30: bom
lah
baloob
l
ah
etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}