import re
regex = re.compile(r"2014(?:(?!2014).)*?baloon.*?(?=\n2014)", flags=re.MULTILINE | re.DOTALL | re.IGNORECASE)
test_str = ("2014.10.30: b\n"
"l\n"
"ah bl\n"
"a\n"
"h \n"
"2014.10.30: bfoo \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: bart1 \n"
"lah \n"
"baloon \n"
"l \n"
"ah \n"
"2014.10.30: carb \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: farb2 \n"
"lah \n"
"baloon \n"
"l \n"
"ah \n"
"2014.10.30: carb \n"
"lah \n"
"b \n"
"l \n"
"ah \n"
"2014.10.30: bom \n"
"lah \n"
"baloob \n"
"l \n"
"ah \n"
"etc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")