#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b([a-zA-Z]\S{8}\d)\b"
Local $sString = "Should match:" & @CRLF & _
"a123456789 aA34567s89 zzzzzzzer9" & @CRLF & _
"" & @CRLF & _
"Not match:" & @CRLF & _
"1123456789 aA34567s8a zzzzzzer9 zzzxzzzze99" & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")