import re
regex = re.compile(r"\b([a-zA-Z]\S{8}\d)\b")
test_str = ("Should match:\n"
"a123456789 aA34567s89 zzzzzzzer9\n\n"
"Not match:\n"
"1123456789 aA34567s8a zzzzzzer9 zzzxzzzze99\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")