use strict;
my $str = 'Should match:
a123456789 aA34567s89 zzzzzzzer9
Not match:
1123456789 aA34567s8a zzzzzzer9 zzzxzzzze99
';
my $regex = qr/\b([a-zA-Z]\S{8}\d)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}