package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)<script[^>]*>.*?<\/script>`)
var str = `<html>
...
<script>
FOO
BAR
</script>
<foo>
<bar>
<script>
FOO
BAR
</script>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}