$re = '/<script[^>]*>.*?<\/script>/mis';
$str = '<html>
...
<script>
FOO
BAR
</script>
<foo>
<bar>
<script>
FOO
BAR
</script>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);