re = /<script[^>]*>.*?<\/script>/mi
str = '<html>
...
<script>
FOO
BAR
</script>
<foo>
<bar>
<script>
FOO
BAR
</script>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end