package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[A-Z]{2}[A-Z0-9]{17,19}$`)
var str = `SI56020170014356205
LV80BANK0000435195001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}