import re
regex = re.compile(r"^[A-Z]{2}[A-Z0-9]{17,19}$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("SI56020170014356205\n"
"LV80BANK0000435195001")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")