$re = '/^[A-Z]{2}[A-Z0-9]{17,19}$/im';
$str = 'SI56020170014356205
LV80BANK0000435195001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);