#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$"
Local $sString = "+49 711 4 20 42 26"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)