import Foundation
let pattern = #"^(?:\+|0|\(\d+\)) ?(?:[0-9] ?){6,14}[0-9]$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+49 711 4 20 42 26"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}