const regex = /\b((?:[9]\s*[7]\s*[8-9]\s*)?\d(?:\s*\d){9})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:[9]\\s*[7]\\s*[8-9]\\s*)?\\d(?:\\s*\\d){9})\\b', 'g')
const str = `foo ISBN10 013 284 1649 0132841648 Web ISBN13 9 78013 2841641 9780132841641 2013 bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}