$re = '/\b((?:[9]\s*[7]\s*[8-9]\s*)?\d(?:\s*\d){9})\b/';
$str = 'foo ISBN10 013 284 1649 0132841648 Web ISBN13 9 78013 2841641 9780132841641 2013 bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);