re = /\b((?:[9]\s*[7]\s*[8-9]\s*)?\d(?:\s*\d){9})\b/
str = 'foo ISBN10 013 284 1649 0132841648 Web ISBN13 9 78013 2841641 9780132841641 2013 bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end