package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\/:]*:\/\/`)
var str = `https://nginx.org/en/docs/http/ngx_http_proxy_module.html#proxy_pass`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}