re = /^[^\/:]*:\/\//m
str = 'https://nginx.org/en/docs/http/ngx_http_proxy_module.html#proxy_pass'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end