$re = '/^[^\/:]*:\/\//m';
$str = 'https://nginx.org/en/docs/http/ngx_http_proxy_module.html#proxy_pass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);