package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?[^|]$`)
var str = `sdlfskdjfl
dfgdfdf|
dgdsg;glkjxg;
sdfdsf|
sdfsdfsdfss
|
|
jlk
1213
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}