re = /^.*?[^|]$/m
str = 'sdlfskdjfl
dfgdfdf|
dgdsg;glkjxg;
sdfdsf|
sdfsdfsdfss
|
|
jlk
1213
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end